Dragon
主机之家测评主机之家测评  2019-08-25 00:28 主机之家测评 隐藏边栏 |   抢沙发  103 
文章评分 0 次,平均分 0.0

最近在学习 Laravel 框架,在 phpstudy 下使用 composer+laravel 安装器的方式安装了 Laravel,但是访问的时候报错:

Warning: require(D:phpstudyWWWpublicmyblogbootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in .../autoload.php on line 17

通过百度了解到在项目根目录运行 composer update 命令可以解决这个问题。

但是我在运行 composer update 时报错,截图如下:

Laravel 框架 Warning: require(../vendor/autoload.php): failed to open stream: No such file or directory in .../autoload.php on line 17 错误的解决办法

很明显,错误表示最新版本的 Laravel5.6 版本需要 php7.1.3 以上版本,但是我的 php 是 7.0.12。

而通过 Laravel 安装器安装 Laravel 框架时无法指定具体版本,最终解决办法就是删掉项目文件,通过 Composer Create-Project 命令指定版本安装 Laravel。

  composer create-project --prefer-dist laravel/laravel myblog 5.5.*

本文为原创文章,版权归所有,欢迎分享本文,转载请保留出处!

发表评论

扫一扫二维码分享